PatchSiren cyber security CVE debrief
CVE-2026-116178 vllm-project CVE debrief
A denial of service vulnerability exists in vLLM versions from 0.20.0 before 0.30.0. Remote attackers can crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint, causing a denial of service through negative text span construction in Qwen2.5-VL position, terminating the engine. This issue affects vLLM deployments using versions between 0.20.0 and 0.29.0, and defenders should assess exposure and prioritize remediation or compensating controls.
- Vendor
- vllm-project
- Product
- vllm
- CVSS
- HIGH 8.2
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-25
- Original CVE updated
- 2026-10-29
- Advisory published
- 2026-10-25
- Advisory updated
- 2026-10-29
Who should care
Defenders responsible for vLLM deployments, especially those using affected versions (0.20.0 to 0.29.0), should assess exposure and prioritize remediation or compensating controls. This includes verifying the version of vLLM in use, evaluating the potential impact of a denial of service attack, and planning for upgrades or mitigations. Security teams and operators managing vLLM should also review and update incident response plans to address potential deni
Why it matters
CVE-2026-116178 is a denial of service vulnerability in vLLM versions 0.20.0 to 0.29.0. Defenders should verify exposure, prioritize remediation or compensating controls, and monitor for suspicious requests.
- Crash of the vLLM engine leading to service disruption
- Potential for attackers to exploit this vulnerability to cause denial of service
- Need for verification of affected versions and exposure
- Prioritization of remediation or compensating controls
Technical summary
The vulnerability exists in vLLM versions 0.20.0 through 0.29.0, allowing remote attackers to crash the engine by sending inconsistent multimodal metadata to the /inference/v1/generate endpoint. This causes a denial of service through negative text span construction in Qwen2.5-VL position. The vulnerability is a result of inconsistent handling of multimodal metadata, leading to engine termination. Defenders should verify exposure of vLLM deployments, especially those using versions between 0.20.0 and 0.29.0, and assess the feasibility of upgrading to version 0.30.0 or applying compensating controls.
Defensive priority
Defenders should prioritize verifying exposure of vLLM deployments, especially those using versions between 0.20.0 and 0.29.0, and assess the feasibility of upgrading to version 0.30.0 or applying compensating controls.
Recommended defensive actions
- Verify vLLM version and assess exposure
- Consider upgrading to version 0.30.0 or later
- Implement compensating controls for affected versions
- Monitor for suspicious multimodal metadata requests
- Review and update incident response plans for potential denial of service attacks
- Conduct vulnerability scanning to identify exposed assets
- Engage with the vendor for additional guidance or support
Evidence notes
The vulnerability allows remote attackers to crash the engine by sending inconsistent multimodal metadata. Affected versions include 0.20.0 through 0.29.0. The CVE Program and NVD provide official records, while osv_dev and Vulncheck offer additional details.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-116178 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-116178
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-116178 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-116178
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
PYSEC-2026-4353
Unverified legacy reference
URL: https://storage.googleapis.com/osv-vulnerabilities/PyPI/PYSEC-2026-4353.json
osv_dev
-
Source reference
Unverified legacy reference
URL: https://www.vulncheck.com/advisories/vllm-0.20.0-before-0.30.0-dos-via-inference-v1-generate-mm-placeholders
Supplemental source
-
Source reference
Unverified legacy reference
URL: https://github.com/vllm-project/vllm/security/advisories/GHSA-34qw-q2h2-jp3m
Supplemental source
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.