A denial-of-service vulnerability exists in zstd-jni versions 1.4.8-4 through 1.5.7-13. The issue arises from the failure to validate negative length parameters in ZstdInputStreamNoFinalizer.read(), allowing attackers to trigger infinite loops. This vulnerability can cause system unavailability and performance degradation, and defenders should verify versions and apply patches or updates as available to m [truncated]
CVE-2026-87825 is a high-severity vulnerability in the zstd-jni library, which is a Java Native Interface (JNI) wrapper for the zstd compression algorithm. The vulnerability is caused by a use-after-free error in the library's handling of streams and contexts, which can lead to silent data corruption or JVM crashes. The vulnerability has been patched in version 1.5.7-14 of the library.
The CVE-2026-87824 vulnerability in zstd-jni before 1.5.7-14 allows attackers to read past buffer boundaries by supplying oversized per-sample lengths to Zstd.trainFromBufferDirect, potentially causing JVM termination. This issue is rated as HIGH with a CVSS score of 8.7. The vulnerability affects systems using zstd-jni, particularly those using versions prior to 1.5.7-14. Defenders should assess exposure [truncated]
The CVE-2026-87795 vulnerability in zstd-jni versions before 1.5.7-14 allows out-of-bounds memory reads due to improper validation of offset and length parameters in the ZstdDictCompress constructor. This can lead to JVM crashes when attackers supply untrusted values. The vulnerability is caused by a lack of validation of offset and length parameters, which can lead to out-of-bounds memory reads. Defender [truncated]