PatchSiren cyber security CVE debrief
CVE-2026-71554 python-hyper CVE debrief
CVE-2026-71554 is a vulnerability in the h2 pure-Python implementation of the HTTP/2 protocol stack. The issue allows for request smuggling when downgrading from HTTP/2 to HTTP/1.1. This occurs because versions up to and including 4.4.0 accept request header blocks with multiple Host headers, which are then forwarded to the consuming application. The vulnerability is fixed in version 4.4.1.
- Vendor
- python-hyper
- Product
- h2
- CVSS
- MEDIUM 5.3
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-08-06
- Original CVE updated
- 2026-09-18
- Advisory published
- 2026-08-06
- Advisory updated
- 2026-09-18
Who should care
Defenders responsible for systems using the h2 library for HTTP/2 communication should be aware of this vulnerability and take steps to mitigate it. This includes upgrading to version 4.4.1 or later and reviewing system configurations for potential exposure.
Why it matters
CVE-2026-71554 is a request smuggling vulnerability in the h2 HTTP/2 protocol stack implementation. Defenders should prioritize upgrading to version 4.4.1 or later and review system configurations to mitigate potential exposure.
- Potential request smuggling attacks
- Exposure of sensitive information
- Downgrade attacks from HTTP/2 to HTTP/1.1
- Verification of system configurations for h2 library usage
Technical summary
The h2 library, a pure-Python implementation of the HTTP/2 protocol stack, is vulnerable to request smuggling. This occurs when the library accepts request header blocks containing multiple Host headers and forwards them to the consuming application. When downgrading from HTTP/2 to HTTP/1.1, this can lead to a request smuggling primitive. The issue is fixed in version 4.4.1. Defenders should prioritize upgrading to version 4.4.1 or later to mitigate this vulnerability. Systems using the h2 library for HTTP/2 communication are potentially affected and should be reviewed for exposure.
Defensive priority
Defenders should prioritize upgrading to version 4.4.1 or later to mitigate this vulnerability. Systems using the h2 library for HTTP/2 communication are potentially affected.
Recommended defensive actions
- Upgrade to version 4.4.1 or later of the h2 library
- Review and update systems using the h2 library for HTTP/2 communication
- Monitor for potential request smuggling attacks
- Verify system configurations for h2 library usage
- Review compensating controls for exposed systems while remediation is scheduled and verified
- Check relevant monitoring, detection, and logs for exposed assets that need extra review
- Track exceptions, retest remediated assets, and close the item only after evidence is documented
Evidence notes
The CVE record and NVD entry provide details on the vulnerability, including its description, CVSS score, and affected versions. The issue is fixed in version 4.4.1 of the h2 library. To verify exposure, defenders should review system configurations for h2 library usage and check for potential request smuggling attacks. The vulnerability allows for request smuggling when downgrading from HTTP/2 to HTTP/1.1 due to the acceptance of multiple Host headers in request header blocks.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-71554 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-71554
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-71554 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-71554
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
Source reference
Unverified legacy reference
URL: https://github.com/python-hyper/h2/commit/292a40829feefda98c8509dcdbbb4a57af9bd6a6
-
Source reference
Unverified legacy reference
URL: https://github.com/python-hyper/h2/security/advisories/GHSA-6hr6-w5qg-qmwg
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.