PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-115930 MongoDB, Inc. CVE debrief

CVE-2026-115930 debrief: MongoDB Shell (mongosh) relies on Node.js with a recoverable eMudhra intermediate CA certificate issue, impacting versions prior to 2.14.0. This issue can be resolved by updating to mongosh 2.14.0 or later, which bundles Node.js 24.22.1 or later. The vulnerability affects MongoDB Shell (mongosh) deployments and can be addressed by prioritizing updates to version 2.14.0 or later. Defenders should assess exposure and update affected deployments to prevent potential issues.

Vendor
MongoDB, Inc.
Product
mongosh
CVSS
HIGH 7.6
CISA KEV
Not listed in stored evidence
Original CVE published
2026-10-26
Original CVE updated
2026-11-02
Advisory published
2026-10-26
Advisory updated
2026-11-02

Who should care

Defenders responsible for MongoDB Shell (mongosh) deployments should assess exposure and prioritize updates to version 2.14.0 or later. This includes operators, platform administrators, vulnerability management teams, and security teams who need to review and update affected deployments to prevent potential issues.

Why it matters

Defenders should prioritize updating MongoDB Shell (mongosh) to version 2.14.0 or later to address the recoverable eMudhra intermediate CA certificate issue, as it impacts versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later.

  • Verify and update MongoDB Shell (mongosh) to version 2.14.0 or later to address the recoverable eMudhra intermediate CA certificate issue
  • Assess and update Node.js runtime if mongosh is installed through npm
  • Review and update affected deployments to prevent potential issues

Technical summary

The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. The vulnerability affects MongoDB Shell (mongosh) deployments and can be addressed by prioritizing updates to version 2.14.0 or later. Defenders should assess exposure and update affected deployments to prevent potential issues. The CVE record and NVD entry provide details on the vulnerability in MongoDB Shell (mongosh) versions prior to 2.14.0.

Defensive priority

Defenders should prioritize updating MongoDB Shell (mongosh) to version 2.14.0 or later to address the recoverable eMudhra intermediate CA certificate issue.

Recommended defensive actions

  • Update MongoDB Shell (mongosh) to version 2.14.0 or later
  • Verify Node.js runtime is up-to-date if mongosh is installed through npm
  • Review and update affected deployments
  • Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up
  • Plan vendor-supported updates or mitigations through normal change control where exposure is confirmed
  • Review compensating controls for exposed systems while remediation is scheduled and verified
  • Check relevant monitoring, detection, and logs for exposed assets that need extra review

Evidence notes

The CVE record and NVD entry provide details on the vulnerability in MongoDB Shell (mongosh) versions prior to 2.14.0, which relies on Node.js with a recoverable eMudhra intermediate CA certificate issue.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-115930 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-115930

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-115930 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-115930

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.