PatchSiren cyber security CVE debrief
CVE-2026-112712 @fastify/middie CVE debrief
The @fastify/middie package, an Express-style middleware engine for Fastify, has a vulnerability in versions 9.0.0 through 9.3.5. The issue arises from how the use() function handles path-scoped middleware's mount path and plugin scope prefix, potentially causing middleware like authentication or rate limiting to be bypassed. This affects systems using @fastify/middie for middleware management.
- Vendor
- @fastify/middie
- Product
- Unknown
- CVSS
- CRITICAL 9.1
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-20
- Original CVE updated
- 2026-10-20
- Advisory published
- 2026-10-20
- Advisory updated
- 2026-10-20
Who should care
Developers and administrators using @fastify/middie for middleware management in Fastify applications should assess exposure and upgrade to version 9.3.6 or later. They should also review affected systems, ensure proper authorization mechanisms are in place, and monitor for potential unauthorized access. Security teams and vulnerability management teams should prioritize this update and verify that affected systems are properly secured.
Why it matters
The vulnerability in @fastify/middie could allow attackers to bypass critical middleware, including authentication and rate limiting, in Fastify applications. Developers and administrators must upgrade to version 9.3.6 or later and review affected systems.
- Potential bypass of authentication mechanisms
- Possible unauthorized access to sensitive data
- Risk of elevated privileges for attackers
- Need for immediate upgrade and verification of affected systems
Technical summary
The @fastify/middie package has a vulnerability in versions 9.0.0 through 9.3.5 where path-scoped middleware could be bypassed due to a mismatch in handling mount paths and scope prefixes. This issue arises from how the use() function joins a path-scoped middleware's mount path to the plugin scope prefix, potentially causing middleware like authentication or rate limiting to be skipped. The vulnerability is fixed in version 9.3.6, and developers should upgrade to this version or later to mitigate the issue. A workaround is to enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
Defensive priority
Upgrade to @fastify/middie version 9.3.6 or later immediately. As a workaround, implement authorization checks in a Fastify hook like preHandler to ensure requests are authenticated.
Recommended defensive actions
- Upgrade to @fastify/middie version 9.3.6 or later
- Implement authorization checks in a Fastify hook like preHandler
- Review and update affected systems using @fastify/middie for middleware management
- Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up
- Review the supplied official advisory or CVE record to validate affected scope, severity, and vendor guidance
- Plan vendor-supported updates or mitigations through normal change control where exposure is confirmed
- Check relevant monitoring, detection, and logs for exposed assets that need extra review
Evidence notes
The CVE record and source item provide details on the vulnerability in @fastify/middie versions 9.0.0 through 9.3.5, including how the issue was fixed in version 9.3.6. Developers should verify affected systems and configurations, review Fastify application setups, and ensure proper authorization mechanisms are in place. Evidence from the CVE Program and other sources indicates that this vulnerability could lead to bypassed authentication and rate limiting, potentially exposing systems to unauthorized access.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-112712 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-112712
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-112712 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-112712
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/112xxx/CVE-2026-112712.json
cve_program_cvelist_v5
-
Source reference
Unverified legacy reference
URL: https://github.com/fastify/middie/security/advisories/GHSA-5p92-8765-9fv8
Supplemental source
-
Source reference
Unverified legacy reference
URL: https://cna.openjsf.org/security-advisories.html
Supplemental source
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.