PatchSiren cyber security CVE debrief
CVE-2026-112838 e4jvikwp CVE debrief
The WordPress VikRentCar plugin version 1.4.8 and earlier has a Cross Site Scripting (XSS) vulnerability due to improper neutralization of input during web page generation. This issue allows stored XSS attacks, potentially impacting WordPress deployments. Defenders should assess exposure and prioritize verification and updates. The CVE record was published on 2026-10-23T08:00:10.440Z and has not been modified since then. The vulnerability has a CVSS score of 7.1 and is classified as HIGH severity.
- Vendor
- e4jvikwp
- Product
- VikRentCar
- CVSS
- HIGH 7.1
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-23
- Original CVE updated
- 2026-10-23
- Advisory published
- 2026-10-23
- Advisory updated
- 2026-10-23
Who should care
Defenders responsible for WordPress deployments using the VikRentCar plugin version 1.4.8 and earlier should assess exposure and prioritize verification and updates.
Why it matters
Defenders should prioritize verifying and updating the VikRentCar plugin to version 1.4.9 or later, and assess exposure in their WordPress deployments, as the Cross Site Scripting (XSS) vulnerability can lead to potential XSS attacks.
- Verification of plugin version and exposure in WordPress deployments
- Potential XSS attacks through stored scripts
Technical summary
The WordPress VikRentCar plugin version 1.4.8 and earlier has a Cross Site Scripting (XSS) vulnerability due to improper neutralization of input during web page generation. This issue allows stored XSS attacks, potentially impacting WordPress deployments. The vulnerability has a CVSS score of 7.1 and is classified as HIGH severity. Defenders should prioritize verifying and updating the VikRentCar plugin to version 1.4.9 or later.
Defensive priority
Defenders should prioritize verifying and updating the VikRentCar plugin to version 1.4.9 or later, and assess exposure in their WordPress deployments.
Recommended defensive actions
- Verify and update the VikRentCar plugin to version 1.4.9 or later
- Assess exposure in WordPress deployments
- Monitor for potential XSS attacks
Evidence notes
The CVE record and source item provide details on the Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin version 1.4.8 and earlier.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-112838 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-112838
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-112838 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-112838
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
WordPress VikRentCar plugin <= 1.4.8 - Cross Site Scripting (XSS) vulnerability
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/112xxx/CVE-2026-112838.json
cve_program_cvelist_v5
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.