PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-112835 e4jvikwp CVE debrief

The WordPress VikRentCar plugin version <= 1.4.8 is vulnerable to Cross Site Scripting (XSS). Defenders responsible for WordPress deployments using the VikRentCar plugin should assess exposure and prioritize verification and updates. The CVE record was published on 2026-10-23T08:00:10.892Z and has not been modified since then. The vulnerability requires verification and updates to prevent potential XSS attacks. The Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin version <= 1.4.8 requires verification and updates to prevent potential XSS attacks.

Vendor
e4jvikwp
Product
VikRentCar
CVSS
HIGH 7.1
CISA KEV
Not listed in stored evidence
Original CVE published
2026-10-23
Original CVE updated
2026-10-23
Advisory published
2026-10-23
Advisory updated
2026-10-23

Who should care

Defenders responsible for WordPress deployments using the VikRentCar plugin should assess exposure and prioritize verification and updates. Defenders must verify and update the VikRentCar plugin to version 1.4.9 or later to prevent potential XSS attacks. WordPress deployments using the VikRentCar plugin version <= 1.4.8 are potentially vulnerable to XSS attacks.

Why it matters

The Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin version <= 1.4.8 requires verification and updates to prevent potential XSS attacks.

  • Defenders must verify and update the VikRentCar plugin to version 1.4.9 or later to prevent potential XSS attacks.
  • WordPress deployments using the VikRentCar plugin version <= 1.4.8 are potentially vulnerable to XSS attacks.

Technical summary

The WordPress VikRentCar plugin version <= 1.4.8 is vulnerable to Cross Site Scripting (XSS). The vulnerability requires verification and updates to prevent potential XSS attacks. Defenders should prioritize verifying and updating the VikRentCar plugin to version 1.4.9 or later, and assess exposure in their WordPress deployments. The Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin version <= 1.4.8 requires verification and updates to prevent potential XSS attacks.

Defensive priority

Defenders should prioritize verifying and updating the VikRentCar plugin to version 1.4.9 or later, and assess exposure in their WordPress deployments.

Recommended defensive actions

  • Verify and update the VikRentCar plugin to version 1.4.9 or later
  • Assess exposure in WordPress deployments
  • Monitor for potential XSS attacks

Evidence notes

The CVE record and source item provide details on the Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin, version <= 1.4.8. The source item provides details on the Cross Site Scripting (XSS) vulnerability in the WordPress VikRentCar plugin. The CVE record was published on 2026-10-23T08:00:10.892Z and has not been modified since then. Defenders must verify and update the VikRentCar plugin to version 1.4.9 or later to prevent potential XSS attacks.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-112835 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-112835

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-112835 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-112835

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.