PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-116107 Datafeedr CVE debrief

A vulnerability was detected in Datafeedr Product Sets Plugin up to 1.3.24 on WordPress. The issue is related to the function dfrps_ajax_delete_saved_search in the file functions/ajax.php, which lacks authorization. This vulnerability can be exploited remotely. The exploit is now public and may be used. Upgrading to version 1.3.25 can resolve this issue.

Vendor
Datafeedr
Product
Product Sets Plugin
CVSS
LOW 2.1
CISA KEV
Not listed in stored evidence
Original CVE published
2026-10-26
Original CVE updated
2026-11-02
Advisory published
2026-10-26
Advisory updated
2026-11-02

Who should care

Defenders responsible for WordPress installations using the Datafeedr Product Sets Plugin up to 1.3.24 should assess exposure and prioritize upgrading to version 1.3.25. They should verify remote exploitation possibility in the environment and review compensating controls for exposed systems while remediation is scheduled and verified.

Why it matters

CVE-2026-116107 is a vulnerability in Datafeedr Product Sets Plugin up to 1.3.24 on WordPress, allowing remote exploitation due to missing authorization. Defenders should prioritize upgrading and assess exposure.

  • Verify remote exploitation possibility in the environment.
  • Assess exposure in WordPress installations using the Datafeedr Product Sets Plugin up to 1.3.24.
  • Prioritize upgrading to version 1.3.25.

Technical summary

The vulnerability is located in the dfrps_ajax_delete_saved_search function of the functions/ajax.php file in the Datafeedr Product Sets Plugin up to 1.3.24 on WordPress. The issue is caused by missing authorization, allowing remote exploitation. This vulnerability can be exploited remotely. The exploit is now public and may be used. Upgrading to version 1.3.25 can resolve this issue. Defenders should assess exposure in WordPress installations using the Datafeedr Product Sets Plugin up to 1.3.24 and verify if remote exploitation is possible in their environment.

Defensive priority

Defenders should prioritize upgrading to version 1.3.25. They should assess exposure in WordPress installations using the Datafeedr Product Sets Plugin up to 1.3.24 and verify if remote exploitation is possible in their environment.

Recommended defensive actions

  • Upgrade to version 1.3.25 of the Datafeedr Product Sets Plugin.
  • Assess exposure in WordPress installations using the Datafeedr Product Sets Plugin up to 1.3.24.
  • Verify if remote exploitation is possible in the environment.
  • Review compensating controls for exposed systems while remediation is scheduled and verified.
  • Check relevant monitoring, detection, and logs for exposed assets that need extra review.
  • Track exceptions, retest remediated assets, and close the item only after evidence is documented.
  • Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up.

Evidence notes

The CVE record and NVD entry provide details about the vulnerability in Datafeedr Product Sets Plugin. The vendor was contacted early about this disclosure, and upgrading to version 1.3.25 is advised.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-116107 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-116107

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-116107 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-116107

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.