PatchSiren cyber security CVE debrief
CVE-2026-116011 CrowCpp CVE debrief
CVE-2026-116011 is a high-severity vulnerability in Crow before version 1.3.4, allowing remote unauthenticated attackers to crash the server by sending deeply nested JSON to the crow::json::load() function, which causes uncontrolled recursion and exhausts the worker thread stack. This vulnerability affects Crow versions prior to 1.3.4 and can be mitigated by updating to the latest version. System administrators and developers using Crow should verify their current version and assess exposure to this vulnerability. Those using Crow versions before 1.3.4 should prioritize updating to prevent denial-of-service attacks.
- Vendor
- CrowCpp
- Product
- Crow
- CVSS
- HIGH 8.7
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-24
- Original CVE updated
- 2026-10-26
- Advisory published
- 2026-10-24
- Advisory updated
- 2026-10-26
Who should care
System administrators and developers using Crow should verify their current version and assess exposure to this vulnerability. Those using Crow versions before 1.3.4 should prioritize updating to prevent denial-of-service attacks.
Why it matters
CVE-2026-116011 is a high-severity vulnerability in Crow before version 1.3.4, allowing remote unauthenticated attackers to crash the server by sending deeply nested JSON to the crow::json::load() function. Defenders should prioritize updating Crow to version 1.3.4 or later to prevent denial-of-service attacks. System administrators and developers using Crow should verify their current version and assess exposure.
- Denial-of-service attacks are possible via deeply nested JSON
- Server crashes and connection drops are potential consequences
- Remediation requires updating to Crow version 1.3.4 or later
- Exposure assessment and version verification are necessary
Technical summary
The vulnerability in Crow before 1.3.4 is caused by uncontrolled recursion in the crow::json::load() function, which allows remote attackers to crash the server by sending deeply nested JSON. The CVSS score for this vulnerability is 8.7, indicating a high severity. This issue can be addressed by updating to Crow version 1.3.4 or later. Defenders should prioritize updating Crow to version 1.3.4 or later to prevent denial-of-service attacks. System administrators and developers using Crow should verify their current version and assess exposure.
Defensive priority
Defenders should prioritize updating Crow to version 1.3.4 or later to prevent denial-of-service attacks. System administrators and developers using Crow should verify their current version and assess exposure.
Recommended defensive actions
- Update Crow to version 1.3.4 or later
- Verify current Crow version in use
- Assess exposure and prioritize remediation
- Review compensating controls for exposed systems while remediation is scheduled and verified
- Check relevant monitoring, detection, and logs for exposed assets that need extra review
- Track exceptions, retest remediated assets, and close the item only after evidence is documented
- Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up
Evidence notes
The CVE record and source item provide details on the vulnerability, including its description, CVSS score, and affected versions. However, the corpus does not establish specific exploitation instances or remediation beyond updating to version 1.3.4.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-116011 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-116011
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-116011 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-116011
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
Crow before 1.3.4 Denial of Service via Deeply Nested JSON in crow::json::load()
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/116xxx/CVE-2026-116011.json
cve_program_cvelist_v5
-
Source reference
Unverified legacy reference
URL: https://github.com/CrowCpp/Crow/security/advisories/GHSA-7x84-xhp8-6cqj
Supplemental source - vendor-advisory
-
Source reference
Unverified legacy reference
URL: https://github.com/CrowCpp/Crow/commit/6956b7ca93c5df22f5aaccd670e5aa000c0d882b
Supplemental source - patch
-
Source reference
Unverified legacy reference
URL: https://github.com/CrowCpp/Crow/releases/tag/v1.3.4
Supplemental source - release-notes
-
Source reference
Unverified legacy reference
URL: https://github.com/CrowCpp/Crow/blob/v1.3.3/include/crow/json.h
Supplemental source - technical-description
-
Source reference
Unverified legacy reference
URL: https://www.vulncheck.com/advisories/crow-before-1.3.4-denial-of-service-via-deeply-nested-json-in-crow-json-load
Supplemental source - third-party-advisory
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.