PatchSiren cyber security CVE debrief
CVE-2026-111843 CozyThemes CVE debrief
A Cross Site Scripting (XSS) vulnerability exists in the WordPress Rootblox plugin versions up to 1.0.7. This issue allows for Stored XSS, potentially impacting users who interact with affected pages. The vulnerability is addressed in version 1.0.8. Defenders managing WordPress environments using the Rootblox plugin should assess exposure and prioritize updates to mitigate potential XSS attacks. This involves verifying the plugin version, assessing the environment for potential exposure, and monitoring for signs of exploitation. The CVE record and source item provide details on the vulnerability, including its existence in versions up to 1.0.7 of the Rootblox plugin and a fix in 1.
- Vendor
- CozyThemes
- Product
- Rootblox
- CVSS
- MEDIUM 6.5
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-20
- Original CVE updated
- 2026-10-21
- Advisory published
- 2026-10-20
- Advisory updated
- 2026-10-21
Who should care
Defenders managing WordPress environments using the Rootblox plugin should assess exposure and prioritize updates to mitigate potential XSS attacks.
Why it matters
CVE-2026-111843 is a Cross Site Scripting (XSS) vulnerability in the WordPress Rootblox plugin versions up to 1.0.7, allowing for Stored XSS attacks. Defenders should prioritize verifying and updating the plugin, assessing exposure in their environments, and monitoring for potential attacks.
- Defenders must verify and update the Rootblox plugin to prevent potential XSS attacks
- Security teams should assess exposure in their WordPress environments
- Incident response teams may need to monitor for potential XSS attacks targeting the Rootblox plugin
Technical summary
The WordPress Rootblox plugin versions up to 1.0.7 contain a Cross Site Scripting (XSS) vulnerability, allowing for Stored XSS attacks. This issue is addressed in version 1.0.8. The vulnerability exists due to improper neutralization of input during web page generation, which can lead to Stored XSS attacks. Defenders should prioritize verifying and updating the Rootblox plugin to version 1.0.8 or later, and assess exposure in their WordPress environments. This includes reviewing the plugin version, assessing the environment for potential exposure, and monitoring
Defensive priority
Defenders should prioritize verifying and updating the Rootblox plugin to version 1.0.8 or later, and assess exposure in their WordPress environments.
Recommended defensive actions
- Verify and update the Rootblox plugin to version 1.0.8 or later
- Assess exposure in WordPress environments using the Rootblox plugin
- Monitor for potential XSS attacks targeting the Rootblox plugin
Evidence notes
The CVE record and source item provide details on the vulnerability, including its existence in versions up to 1.0.7 of the Rootblox plugin and a fix in version 1.0.8.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-111843 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-111843
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-111843 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-111843
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
WordPress Rootblox plugin <= 1.0.7 - Cross Site Scripting (XSS) vulnerability
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/111xxx/CVE-2026-111843.json
cve_program_cvelist_v5
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.