PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-33889 apostrophecms CVE debrief

ApostropheCMS versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in the @apostrophecms/color-field module. An editor can inject a value which closes the style tag and executes arbitrary JavaScript in the browser of every visitor to any page containing the affected widget. This vulnerability allows for mass session hijacking, cookie theft, and privilege escalation to administrative control if an admin views draft content. The issue has been fixed in version 4.29.0.

Vendor
apostrophecms
Product
apostrophe
CVSS
MEDIUM 5.4
CISA KEV
Not listed in stored evidence
Original CVE published
2026-04-15
Original CVE updated
2026-10-26
Advisory published
2026-04-15
Advisory updated
2026-10-26

Who should care

Defenders responsible for ApostropheCMS installations, particularly those with editor-level access, should assess exposure and apply the patch to prevent exploitation. This includes operators, administrators, and security teams managing ApostropheCMS deployments. Verification of exposure and patch application are crucial to prevent exploitation.

Why it matters

Defenders should care about CVE-2026-33889 because it allows an editor to inject malicious JavaScript code, leading to mass session hijacking, cookie theft, and privilege escalation. Verification of exposure and patch application are crucial to prevent exploitation.

  • Mass session hijacking through JavaScript injection
  • Cookie theft through malicious script execution
  • Privilege escalation to administrative control if an admin views draft content
  • Verification of exposure and patch application priority

Technical summary

The @apostrophecms/color-field module in ApostropheCMS versions 4.28.0 and prior does not properly sanitize color values, allowing an editor to inject malicious JavaScript code. This enables mass session hijacking, cookie theft, and privilege escalation to administrative control if an admin views draft content. The issue has been fixed in version 4.29.0. Defenders should prioritize verifying exposure and applying the patch to prevent exploitation. The vulnerability allows for mass session hijacking, cookie theft, and privilege escalation.

Defensive priority

Defenders should prioritize verifying exposure and applying the patch to prevent exploitation.

Recommended defensive actions

  • Verify exposure by checking if the ApostropheCMS version is 4.28.0 or prior
  • Apply the patch by upgrading to ApostropheCMS version 4.29.0 or later
  • Monitor for suspicious activity on the affected widget
  • Review compensating controls for exposed systems while remediation is scheduled and verified
  • Check relevant monitoring, detection, and logs for exposed assets that need extra review
  • Track exceptions, retest remediated assets, and close the item only after evidence is documented
  • Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up

Evidence notes

The CVE record and NVD entry provide details on the vulnerability, including its description, CVSS score, and affected versions. The @apostrophecms/color-field module in ApostropheCMS versions 4.28.0 and prior does not properly sanitize color values, allowing an editor to inject malicious JavaScript code. Verification of exposure and patch application are crucial to prevent exploitation.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-33889 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-33889

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-33889 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-33889

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

  • Source reference

    Unverified legacy reference

    URL: https://github.com/apostrophecms/apostrophe/commit/6a89bdb7acdb2e1e9bf1429961a6ba7f99410481

    [email protected] - Patch

  • Source reference

    Unverified legacy reference

    URL: https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-97v6-998m-fp4g

    [email protected] - Exploit, Mitigation, Vendor Advisory

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.