PatchSiren cyber security CVE debrief
CVE-2026-113661 apostrophecms CVE debrief
ApostropheCMS, a Node.js content management system, uses the sanitize-html library, which had a vulnerability allowing unsafe script or redirect destinations in meta refresh content. This issue, related to CVE-2026-53606, is fixed in sanitize-html version 2.18.0. Defenders should assess exposure and update to mitigate potential security risks. The vulnerability impacts ApostropheCMS installations using non-default configurations that allow meta refresh elements. Verification and updates to sanitize-html and ApostropheCMS are necessary to address potential security risks associated with meta refresh elements.
- Vendor
- apostrophecms
- Product
- apostrophe
- CVSS
- MEDIUM 5.4
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-20
- Original CVE updated
- 2026-10-21
- Advisory published
- 2026-10-20
- Advisory updated
- 2026-10-21
Who should care
Defenders responsible for ApostropheCMS and sanitize-html installations should assess exposure and update to mitigate potential security risks. This includes operators, platform administrators, vulnerability management teams, and security teams who need to verify and update sanitize-html to version 2.18.0 or later. They should review and update ApostropheCMS to ensure compatibility with the updated sanitize-html version and assess and update any affected
Why it matters
Defenders should prioritize verifying and updating sanitize-html to version 2.18.0 or later to address potential security risks associated with meta refresh elements in ApostropheCMS.
- Potential security risks due to unsafe script or redirect destinations in meta refresh content
- Need for verification and updates to sanitize-html and ApostropheCMS
Technical summary
The sanitize-html library used in ApostropheCMS had a vulnerability that allowed unsafe script or redirect destinations in meta refresh content. This issue is fixed in sanitize-html version 2.18.0. Defenders should prioritize verifying and updating sanitize-html to version 2.18.0 or later to address potential security risks associated with meta refresh elements in ApostropheCMS. The vulnerability impacts non-default configurations that allow meta refresh elements and their http-equiv and content attributes. Verification and updates to sanitize-html and ApostropheCMS are necessary.
Defensive priority
Defenders should prioritize verifying and updating sanitize-html to version 2.18.0 or later to address potential security risks associated with meta refresh elements.
Recommended defensive actions
- Verify and update sanitize-html to version 2.18.0 or later
- Review and update ApostropheCMS to ensure compatibility with the updated sanitize-html version
- Assess and update any affected systems or applications using ApostropheCMS and sanitize-html
- Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up
- Review the supplied official advisory or CVE record to validate affected scope, severity, and vendor guidance
- Plan vendor-supported updates or mitigations through normal change control where exposure is confirmed
- Check relevant monitoring, detection, and logs for exposed assets that need extra review
Evidence notes
The CVE record and source item provide details on the vulnerability in sanitize-html, which is used in ApostropheCMS. The issue allows non-default configurations to retain unsafe script or redirect destinations in meta refresh content. Defenders should verify and update sanitize-html to version 2.18.0 or later. The CVE record was published on 2026-10-20T17:11:20.577Z and has not been modified since then. Evidence limits and source grounding indicate potential security risks due to unsafe script or redirect destinations in meta refresh
Sources and references
Verified primary and authoritative sources
-
CVE-2026-113661 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-113661
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-113661 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-113661
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
ApostropheCMS: Incomplete CVE-2026-53606: `meta http-equiv=refresh` `content` still ships `javas
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/113xxx/CVE-2026-113661.json
cve_program_cvelist_v5
-
Source reference
Unverified legacy reference
URL: https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-cv27-6wvh-8x7j
Supplemental source - x_refsource_CONFIRM
-
Source reference
Unverified legacy reference
URL: https://github.com/apostrophecms/apostrophe/commit/9500b8b0e1d630d5e07fbb5fd2c25ed0943845ce
Supplemental source - x_refsource_MISC
-
Source reference
Unverified legacy reference
URL: https://github.com/apostrophecms/apostrophe/commit/f84fd41cbf6c22eb8d0008fc9c25df1f7130b350
Supplemental source - x_refsource_MISC
-
Source reference
Unverified legacy reference
URL: https://github.com/apostrophecms/apostrophe/releases/tag/[email protected]
Supplemental source - x_refsource_MISC
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.