PatchSiren cyber security CVE debrief
CVE-2026-69080 Apache Software Foundation CVE debrief
Apache Kylin users should assess exposure to the Broken Access Control in QuerySQLBlacklistController and upgrade to version 5.0.5 to fix the vulnerability affecting versions 4 through 5.0.4. This issue allows unauthorized actors to access the SQL black list, potentially leading to data exposure. Users must verify their instances' exposure and apply the necessary updates to prevent exploitation. The CVE record and source item provide details on the vulnerability, and administrators should review the official advisory for specific guidance.
- Vendor
- Apache Software Foundation
- Product
- Apache Kylin
- CVSS
- HIGH 7.5
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-16
- Original CVE updated
- 2026-10-20
- Advisory published
- 2026-10-16
- Advisory updated
- 2026-10-20
Who should care
Apache Kylin administrators and users, as well as security teams and vulnerability management teams, should be aware of this vulnerability. They should assess the exposure of their Apache Kylin instances and apply the necessary updates to prevent exploitation. Additionally, operators and platform administrators may need to review the official advisory for specific guidance on mitigating the vulnerability.
Why it matters
Apache Kylin users should assess exposure and upgrade to version 5.0.5 to fix the Broken Access Control in QuerySQLBlacklistController, which affects versions 4 through 5.0.4.
- Verify exposure of Apache Kylin instances to unauthorized actors
- Assess potential for SQL black list exposure
- Upgrade to version 5.0.5 to fix the vulnerability
Technical summary
Apache Kylin versions 4 through 5.0.4 are affected by a Broken Access Control vulnerability in QuerySQLBlacklistController. This vulnerability allows unauthorized access to the SQL black list, potentially leading to data exposure. The issue is fixed in version 5.0.5, and users are advised to upgrade to this version. The vulnerability's technical details indicate that it is a high-severity issue, with a CVSS score of 7.5.
Defensive priority
Upgrade to version 5.0.5
Recommended defensive actions
- Upgrade Apache Kylin to version 5.0.5
- Assess exposure of Apache Kylin versions 4 through 5.0.4
- Verify inventory of Apache Kylin instances
Evidence notes
The CVE record and source item provide details on the vulnerability in Apache Kylin versions 4 through 5.0.4. Evidence from these sources indicates a Broken Access Control vulnerability in QuerySQLBlacklistController, which may expose the SQL black list to unauthorized actors. Defenders should verify the exposure of Apache Kylin instances and assess potential impacts. The official CVE Program record and NIST NVD detail page offer additional context.
Sources and references
Verified primary and authoritative sources
-
CVE-2026-69080 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-69080
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-69080 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-69080
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
Apache Kylin: Broken Access Control in QuerySQLBlacklistController
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/69xxx/CVE-2026-69080.json
cve_program_cvelist_v5
-
Source reference
Unverified legacy reference
URL: https://lists.apache.org/thread.html/zrt6z545y8z9qtsbyzfy55sdpf75osnp
Supplemental source - vendor-advisory
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.