PatchSiren cyber security CVE debrief
CVE-2026-68572 Apache Software Foundation CVE debrief
Apache Kylin users should assess exposure and prioritize upgrading to version 5.0.5 to address unauthorized SQL execution vulnerability. This vulnerability affects Apache Kylin versions 4 through 5.0.4, allowing unauthorized SQL execution to Spark SQL environments. Users and administrators must verify affected versions and upgrade to 5.0.5 to mitigate potential unauthorized access and data exposure risks associated with this vulnerability. Verify and inventory affected versions 4 through 5.0.4, and monitor for potential unauthorized SQL execution attempts.
- Vendor
- Apache Software Foundation
- Product
- Apache Kylin
- CVSS
- HIGH 7.5
- CISA KEV
- Not listed in stored evidence
- Original CVE published
- 2026-10-16
- Original CVE updated
- 2026-10-20
- Advisory published
- 2026-10-16
- Advisory updated
- 2026-10-20
Who should care
Apache Kylin users, administrators, and security teams should assess exposure and prioritize upgrading to version 5.0.5. Operators and platform administrators must verify affected versions 4 through 5.0.4 and implement necessary mitigations to prevent unauthorized SQL execution attempts. Vulnerability management and security teams should monitor for potential unauthorized SQL execution attempts and review compens
Why it matters
Apache Kylin users should assess exposure and prioritize upgrading to version 5.0.5 to address unauthorized SQL execution vulnerability.
- Verify and inventory affected versions 4 through 5.0.4
- Upgrade to version 5.0.5 to address vulnerability
- Monitor for potential unauthorized SQL execution attempts
Technical summary
Apache Kylin versions 4 through 5.0.4 are vulnerable to unauthorized SQL execution to Spark SQL environments. This vulnerability allows attackers to execute unauthorized SQL queries, potentially leading to data exposure and unauthorized access. The recommended mitigation is to upgrade to version 5.0.5, which addresses the vulnerability. Affected users and administrators should assess exposure, verify affected versions, and prioritize upgrading to 5.0.5.
Defensive priority
Upgrade to version 5.0.5; verify affected versions 4 through 5.0.4.
Recommended defensive actions
- Upgrade Apache Kylin to version 5.0.5
- Verify and inventory affected versions 4 through 5.0.4
- Monitor for potential unauthorized SQL execution attempts
Evidence notes
The CVE record and source item provide details on the vulnerability in Apache Kylin versions 4 through 5.0.4. Evidence from the CVE Program and NVD detail pages confirms the vulnerability's existence and provides source-grounded information on affected versions and recommended upgrades. The vulnerability allows unauthorized SQL execution to Spark SQL environments, posing risks of data exposure and unauthorized access. Defenders should verify affected product deployments, review vendor
Sources and references
Verified primary and authoritative sources
-
CVE-2026-68572 CVE Program record
Publisher, destination, and source semantics verified
URL: https://www.cve.org/CVERecord?id=CVE-2026-68572
CVE Program - Official CVE Program record with source-provided CVE metadata.
-
CVE-2026-68572 NVD vulnerability detail
Publisher, destination, and source semantics verified
URL: https://nvd.nist.gov/vuln/detail/CVE-2026-68572
NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.
Supplemental references
-
Apache Kylin: Unauthorized SQL execution to Spark SQL env
Unverified legacy reference
URL: https://raw.githubusercontent.com/CVEProject/cvelistV5/main/cves/2026/68xxx/CVE-2026-68572.json
cve_program_cvelist_v5
-
Source reference
Unverified legacy reference
URL: https://lists.apache.org/thread.html/r0boyqp211s7316oclh666bq40vbs9n7
Supplemental source - vendor-advisory
Methodology and review provenance
AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.