PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-31923 Apache Software Foundation CVE debrief

Apache APISIX has a Cleartext Transmission of Sensitive Information vulnerability due to the `ssl_verify` setting in the openid-connect plugin configuration being set to false by default. This affects Apache APISIX versions from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue. The vulnerability allows sensitive information to be transmitted in cleartext, potentially leading to unauthorized access. Defenders should assess their exposure and prioritize upgrading to version 3.16.0. They should also verify the configuration of the openid-connect plugin and ensure that sensitive information is not transmitted in cleartext.

Vendor
Apache Software Foundation
Product
Apache APISIX
CVSS
HIGH 7.5
CISA KEV
Not listed in stored evidence
Original CVE published
2026-04-14
Original CVE updated
2026-10-26
Advisory published
2026-04-14
Advisory updated
2026-10-26

Who should care

Defenders who use Apache APISIX should assess their exposure and prioritize upgrading to version 3.16.0. They should also verify the configuration of the openid-connect plugin and ensure that sensitive information is not transmitted in cleartext.

Why it matters

Defenders should care about CVE-2026-31923 because it allows sensitive information to be transmitted in cleartext, potentially leading to unauthorized access. They should assess their exposure, prioritize upgrading to version 3.16.0, and verify the configuration of the openid-connect plugin.

  • Sensitive information may be transmitted in cleartext, potentially leading to unauthorized access.
  • The vulnerability may allow attackers to intercept and read sensitive information.

Technical summary

The vulnerability is caused by the `ssl_verify` setting in the openid-connect plugin configuration being set to false by default. This allows sensitive information to be transmitted in cleartext. The issue affects Apache APISIX versions from 0.7 through 3.15.0. The vulnerability can be mitigated by upgrading to version 3.16.0, verifying the configuration of the openid-connect plugin, and ensuring that sensitive information is not transmitted in cleartext. Defenders should prioritize upgrading to version 3.16.0 to mitigate the vulnerability.

Defensive priority

Defenders should prioritize upgrading to version 3.16.0 to mitigate the vulnerability. They should also verify the configuration of the openid-connect plugin and ensure that sensitive information is not transmitted in cleartext.

Recommended defensive actions

  • Upgrade to Apache APISIX version 3.16.0
  • Verify the configuration of the openid-connect plugin
  • Ensure sensitive information is not transmitted in cleartext
  • Review compensating controls for exposed systems while remediation is scheduled and verified
  • Check relevant monitoring, detection, and logs for exposed assets that need extra review
  • Track exceptions, retest remediated assets, and close the item only after evidence is documented
  • Confirm whether affected product deployments exist in managed environments and assign an owner for follow-up

Evidence notes

The vulnerability is caused by the `ssl_verify` setting in the openid-connect plugin configuration being set to false by default. This allows sensitive information to be transmitted in cleartext. The issue affects Apache APISIX versions from 0.7 through 3.15.0.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-31923 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-31923

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-31923 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-31923

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.