PatchSiren

PatchSiren cyber security CVE debrief

CVE-2026-39423 1Panel-dev CVE debrief

CVE-2026-39423 is a Stored Cross-Site Scripting (XSS) vulnerability in MaxKB, an open-source AI assistant for enterprise, affecting versions 2.7.1 and below. The vulnerability is due to an Eval Injection issue in the Markdown rendering engine, allowing users to execute arbitrary JavaScript in the browsers of other users, including administrators. This issue has been fixed in version 2.8.0.

Vendor
1Panel-dev
Product
MaxKB
CVSS
MEDIUM 6.9
CISA KEV
Not listed in stored evidence
Original CVE published
2026-04-14
Original CVE updated
2026-10-26
Advisory published
2026-04-14
Advisory updated
2026-10-26

Who should care

Defenders responsible for MaxKB deployments should assess exposure and prioritize upgrading to version 2.8.0 or later. They should also review compensating controls for exposed systems, monitor for suspicious activity, and track exceptions and retest remediated assets. Security teams and administrators interacting with the AI chat interface are particularly affected.

Why it matters

CVE-2026-39423 is a Stored Cross-Site Scripting (XSS) vulnerability in MaxKB, affecting versions 2.7.1 and below, allowing users to execute arbitrary JavaScript in the browsers of other users, including administrators. Defenders should prioritize upgrading to version 2.8.0 or later to prevent exploitation.

  • Execution of arbitrary JavaScript in the browsers of other users
  • Stored Cross-Site Scripting (XSS) vulnerability
  • Potential for administrators to be affected

Technical summary

The vulnerability is due to an Eval Injection issue in the Markdown rendering engine of MaxKB, allowing users to execute arbitrary JavaScript in the browsers of other users, including administrators. This issue affects MaxKB versions 2.7.1 and below and has been fixed in version 2.8.0. The vulnerability allows for Stored Cross-Site Scripting (XSS) attacks, potentially affecting administrators and other users interacting with the AI chat interface. Defenders should prioritize upgrading to version 2.8.0 or later to prevent exploitation.

Defensive priority

Defenders should prioritize upgrading to version 2.8.0 or later to prevent exploitation.

Recommended defensive actions

  • Upgrade to version 2.8.0 or later
  • Restrict access to the AI chat interface
  • Monitor for suspicious activity
  • Review compensating controls for exposed systems
  • Check relevant monitoring, detection, and logs for exposed assets
  • Track exceptions and retest remediated assets
  • Confirm whether affected product deployments exist in managed environments

Evidence notes

The CVE record and NVD vulnerability detail provide information on the vulnerability, its impact, and the fixed version. The vulnerability affects MaxKB versions 2.7.1 and below, allowing users to execute arbitrary JavaScript in the browsers of other users, including administrators. Defenders should verify affected deployments and prioritize upgrading to version 2.8.0 or later. Evidence is limited to public CVE and NVD details.

Sources and references

Verified primary and authoritative sources

  • CVE-2026-39423 CVE Program record

    Publisher, destination, and source semantics verified

    URL: https://www.cve.org/CVERecord?id=CVE-2026-39423

    CVE Program - Official CVE Program record with source-provided CVE metadata.

  • CVE-2026-39423 NVD vulnerability detail

    Publisher, destination, and source semantics verified

    URL: https://nvd.nist.gov/vuln/detail/CVE-2026-39423

    NIST National Vulnerability Database - Official NIST NVD detail page and source-specific vulnerability assessment.

Supplemental references

Methodology and review provenance

AI-assisted synthesis based on stored public vulnerability evidence. System validation, approval state, and publication status do not by themselves establish human review of this revision. PatchSiren helps prioritize defensive review and does not prove exposure or remediation on any system.